Bug #2099

RCP: 0.7.8, Ubuntu, FactoMineR needs R 3.3.2 to be install

Added by Matthieu Decorde about 2 years ago. Updated about 2 years ago.

Status:New Start date:04/04/2017
Priority:Normal Due date:
Assignee:- % Done:

80%

Category:Setup Spent time: -
Target version:TXM 0.7.8

Description

During the TXM Debian installation, TXM stops because FactoMineR needs R 3.3.2.

hypothesis
Does the fetched FactoMineR sources version depend on R version ?

Test: install FactoMineR using R 3.0.2 (Ubuntu 14.04 default version). FactoMineR should ask R 3.3.2

Test result FROM WINDOWS: when called from R 3.1 "install.packages("FactoMineR", repos="http://cran.rstudio.com/"), the function will try to find out the packages in https://cloud.r-project.org/bin/windows/contrib/3.1/ :

> install.packages("FactoMineR", repos="http://cran.rstudio.com/")
Installing package into 'C:/Users/màtté/Documents/R/win-library/3.1'
(as 'lib' is unspecified)
trying URL 'http://cran.rstudio.com/bin/windows/contrib/3.1/FactoMineR_1.32.zip'

Content type 'application/zip' length 3544346 bytes (3.4 Mb)
opened URL
downloaded 3.4 Mb

package 'FactoMineR' successfully unpacked and MD5 sums checked

Test result FROM LINUX: The https://cloud.r-project.org/src/contrib contains only the last version of packages and there is no sub-directories per version that contains older version of packages.

> install.packages("FactoMineR")
Installing package into ‘/home/alavrent/R/x86_64-pc-linux-gnu-library/3.0’
(as ‘lib’ is unspecified)
--- SVP sélectionner un miroir CRAN pour cette session ---
Avis : impossible d'accéder à l'index de l'entrepôt https://cloud.r-project.org/src/contrib
Message d'avis :
package ‘FactoMineR’ is not available (for R version 3.0.2) 

Solution 1

Install R 3.3.2 and restart TXM installation

Solution 2

Install a FactoMineR compatible with the current R version.
→ use another package repository ?
→ use an install.packages option to use a certain version of FactoMineR ?

Versions table:

OS    R    FactoMineR
12.04    2.14.1    <= 1.33
14.04    3.0.2    <= 1.33
16.04    3.2.3    <= 1.33
16.10    3.3.1    >= 1.34

Since FactoMineR 1.34 the DESCRIPTION file requieres R >= 3.3.0

The install.packages has no option to select the version to install.

To install a specific package one must give the exact path to the package :

factourl <- "https://cran.r-project.org/src/contrib/Archive/FactoMineR/FactoMineR_1.33.tar.gz" 
install.packages(factourl, dependencies=FALSE, repos=NULL, method="wget", type="source");

But with this last instruction, the dependencies are not installed:
factourl <- "https://cran.r-project.org/src/contrib/Archive/FactoMineR/FactoMineR_1.33.tar.gz" 
install.packages(factourl, dependencies=FALSE, repos=NULL, method="wget", type="source");

History

#1 Updated by Matthieu Decorde about 2 years ago

  • Description updated (diff)

#2 Updated by Matthieu Decorde about 2 years ago

  • Description updated (diff)

#3 Updated by Matthieu Decorde about 2 years ago

  • Description updated (diff)

#4 Updated by Matthieu Decorde about 2 years ago

  • Description updated (diff)

#5 Updated by Matthieu Decorde about 2 years ago

  • Description updated (diff)

#6 Updated by Matthieu Decorde about 2 years ago

  • % Done changed from 0 to 80

fixed now that R 3.3.2 is embeded

Also available in: Atom PDF