Bug #633

RCP: 0.7.5, Mac OS X SearchEngine cannot start

Added by Matthieu Decorde over 5 years ago. Updated almost 5 years ago.

Status:New Start date:02/24/2014
Priority:Normal Due date:
Assignee:- % Done:

70%

Category:- Spent time: -
Target version:TXM 0.7.7

Description

Error message is :
Démarrage...
Failed to load CQP lib with exception: java.lang.UnsatisfiedLinkError: /Applications/TXM/cwb/bin/libcqpjni.dylib: Library not loaded: /opt/local/lib/libpcre.1.dylib Referenced from: /Applications/TXM/cwb/bin/libcqpjni.dylib Reason: image not found

Note : /opt/local/lib is not created
need to fix the installer

Failed to load CQP lib with exception: java.lang.UnsatisfiedLinkError: /Applications/TXM/cwb/bin/libcqpjni.dylib: dlopen(/Applications/TXM/cwb/bin/libcqpjni.dylib, 1): Library not loaded: /opt/local/lib/libpcre.1.dylib

  Referenced from: /Applications/TXM/cwb/bin/libcqpjni.dylib

  Reason: Incompatible library version: libcqpjni.dylib requires version 4.0.0 or later, but libpcre.1.dylib provides version 2.0.0

Looking for Cqi libs in : /Users/Travail/Library/Java/Extensions:/Library/Java/Extensions:/Network/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java:.:/Applications/TXM/cwb/bin/

Current directory: /Applications/TXM/TXM/.main.app/Contents/MacOS/.

java.lang.Exception: java.lang.UnsatisfiedLinkError: /Applications/TXM/cwb/bin/libcqpjni.dylib: dlopen(/Applications/TXM/cwb/bin/libcqpjni.dylib, 1): Library not loaded: /opt/local/lib/libpcre.1.dylib

  Referenced from: /Applications/TXM/cwb/bin/libcqpjni.dylib

  Reason: Incompatible library version: libcqpjni.dylib requires version 4.0.0 or later, but libpcre.1.dylib provides version 2.0.0

Solution

Force lib replacement during the installation

History

#1 Updated by Sebastien Jacquot about 5 years ago

  • Target version changed from TXM 0.7.5 to TXM 0.7.7

#2 Updated by Matthieu Decorde almost 5 years ago

  • Description updated (diff)
  • % Done changed from 80 to 70

#3 Updated by Sebastien Jacquot almost 5 years ago

I confirm this bug under Mac OS 10.9.4 VM. (The previous setups worked so it may be linked to the JVM embedding)

#4 Updated by Matthieu Decorde almost 5 years ago

  • Status changed from New to Feedback

#5 Updated by Sebastien Jacquot almost 5 years ago

  • Status changed from Feedback to New

Successfully tested on OS X 10.9.4 VM.

Also available in: Atom PDF