Bug #2035

RCP, 0.7.7: Update fails with error and null value (win32)

Added by Sebastien Jacquot over 3 years ago. Updated 7 months ago.

Status:Closed Start date:02/11/2017
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Update Spent time: -
Target version:TXM 0.8.2

Description

Update from stable 0.7.7.201508311259 to stable 0.7.8 fails with error and null value on Windows XP 32bit. After restart, the splash screen then shows 0.7.8 but the update has not been applied.

Dialog error:

Une erreur s’est produite lors de la désinstallation
session context was:(profile=profile, phase=org.eclipse.equinox.internal.p2.engine.phases.Uninstall, operand=[R]org.txm.rcp_root.win32.win32.x86 0.7.7.201508311259 --> null, action=org.eclipse.equinox.internal.p2.touchpoint.natives.actions.CleanupzipAction).
Backup of file D:\Tools\Coding\TEXTOMETRIE\TXM_0.7.7\TXM\TXM.exe failed.
File that was copied to backup could not be deleted: D:\Tools\Coding\TEXTOMETRIE\TXM_0.7.7\TXM\TXM.exe

See: https://bugs.eclipse.org/bugs/show_bug.cgi?id=333355


Related issues

related to Bug #2724: Updates may fail on some Windows versions due to user fil... New 01/17/2020

History

#1 Updated by Sebastien Jacquot over 3 years ago

  • Description updated (diff)

#2 Updated by Sebastien Jacquot over 3 years ago

Its seems this bug is still present in Luna 4.4.2. We may need to upgrade TXM to Neon.

Temporary Workaround:

  • launch TXM 0.7.7
  • when TXM is started and the updates windows appears, rename TXM.exe to TXM.old.exe (TXM.exe is located in [installation directory]\TXM
  • apply the update and restart TXM

#3 Updated by Matthieu Decorde over 3 years ago

  • Target version changed from TXM 0.7.8 to TXM 0.8.0a (split/restructuration)

#4 Updated by Sebastien Jacquot about 2 years ago

  • Target version changed from TXM 0.8.0a (split/restructuration) to TXM 0.8.0

#5 Updated by Matthieu Decorde over 1 year ago

  • Target version changed from TXM 0.8.0 to TXM X.X

#6 Updated by Sebastien Jacquot 7 months ago

  • Target version changed from TXM X.X to TXM 0.8.2

#7 Updated by Sebastien Jacquot 7 months ago

  • Status changed from New to Closed

Obsolete issue. The bug has been fixed in Eclipse >= Luna.
But a new issue seems to appear in Oxygen + Windows 10, see: linked issue #2724.

Also available in: Atom PDF