Bug #1732

CA chart, extended mouse items selection doesn't work as expected

Added by Sebastien Jacquot over 3 years ago. Updated 10 months ago.

Status:Closed Start date:03/11/2016
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:Charts Spent time: -
Target version:TXM 0.8.0

Description

The extended mouse items selection doesn't work as expected, it's related to cyclic items order selection system.

Steps to reproduce

  • create a CA on VOEUX_text_annee_corpus
  • left click on the "1973" column point in the chart
  • SHIFT + left click on the "1977" column point
    => wrong range of points is selected

Actually, it also doesn't work when the info columns table is sorted on label descending order.
Need to see the code linked to the extended selection with keyboard because it works as expected using keyboard according to the current sorting order.

History

#1 Updated by Sebastien Jacquot over 1 year ago

  • Target version changed from TXM 0.8.0a (split/restructuration) to TXM 0.8.0

#2 Updated by Sebastien Jacquot 10 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Fixed.

Also available in: Atom PDF