Bug #1403

TBX: Nullpointer exception when trying to pop the selected chart entities for drawing them after unselected entities.

Added by Sebastien Jacquot over 4 years ago. Updated over 1 year ago.

Status:Closed Start date:06/17/2015
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:Charts Spent time: -
Target version:TXM 0.8.0

Description

Nullpointer exception when trying to pop the selected chart entities for drawing them after unselected entities.

Ubuntu 12, log:

Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
    at
org.txm.tbx.chartsengine.jfreechart.renderers.ItemSelector.popItemToDrawAsLast(ItemSelector.java:294)
    at
org.txm.tbx.chartsengine.jfreechart.themes.highcharts.defaulttheme.renderers.ItemSelectionXYLineAndShapeRenderer.drawItem(ItemSelectionXYLineAndShapeRenderer.java:309)
    at org.jfree.chart.plot.XYPlot.render(XYPlot.java:3808)
    at org.jfree.chart.plot.XYPlot.draw(XYPlot.java:3342)
    at org.jfree.chart.JFreeChart.draw(JFreeChart.java:1242)
    at org.jfree.chart.ChartPanel.paintComponent(ChartPanel.java:1629)
    at javax.swing.JComponent.paint(JComponent.java:1055)
    at javax.swing.JComponent.paintToOffscreen(JComponent.java:5232)
    at
javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1529)
    at
javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1452)
    at
javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:311)
    at javax.swing.RepaintManager.paint(RepaintManager.java:1249)
    at javax.swing.JComponent._paintImmediately(JComponent.java:5180)
    at javax.swing.JComponent.paintImmediately(JComponent.java:4991)
    at javax.swing.RepaintManager$3.run(RepaintManager.java:808)
    at javax.swing.RepaintManager$3.run(RepaintManager.java:796)
    at java.security.AccessController.doPrivileged(Native Method)
    at
java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
    at
javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:796)
    at
javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:769)
    at
javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:718)
    at javax.swing.RepaintManager.access$1100(RepaintManager.java:62)
    at
javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1677)
    at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
    at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:738)
    at java.awt.EventQueue.access$300(EventQueue.java:103)
    at java.awt.EventQueue$3.run(EventQueue.java:699)
    at java.awt.EventQueue$3.run(EventQueue.java:697)
    at java.security.AccessController.doPrivileged(Native Method)
    at
java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:708)
    at
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
    at
java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
    at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
    at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
    at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
    at
org.txm.tbx.chartsengine.jfreechart.renderers.ItemSelector.popItemToDrawAsLast(ItemSelector.java:294)
    at
org.txm.tbx.chartsengine.jfreechart.themes.highcharts.defaulttheme.renderers.ItemSelectionXYLineAndShapeRenderer.drawItem(ItemSelectionXYLineAndShapeRenderer.java:309)
    at org.jfree.chart.plot.XYPlot.render(XYPlot.java:3808)
    at org.jfree.chart.plot.XYPlot.draw(XYPlot.java:3342)
    at org.jfree.chart.JFreeChart.draw(JFreeChart.java:1242)
    at org.jfree.chart.ChartPanel.paintComponent(ChartPanel.java:1629)
    at javax.swing.JComponent.paint(JComponent.java:1055)
    at javax.swing.JComponent.paintToOffscreen(JComponent.java:5232)
    at
javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1529)
    at
javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1452)
    at
javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:311)
    at javax.swing.RepaintManager.paint(RepaintManager.java:1249)
    at javax.swing.JComponent._paintImmediately(JComponent.java:5180)
    at javax.swing.JComponent.paintImmediately(JComponent.java:4991)
    at javax.swing.RepaintManager$3.run(RepaintManager.java:808)
    at javax.swing.RepaintManager$3.run(RepaintManager.java:796)
    at java.security.AccessController.doPrivileged(Native Method)
    at
java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
    at
javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:796)
    at
javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:769)
    at
javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:718)
    at javax.swing.RepaintManager.access$1100(RepaintManager.java:62)
    at
javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1677)
    at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
    at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:738)
    at java.awt.EventQueue.access$300(EventQueue.java:103)
    at java.awt.EventQueue$3.run(EventQueue.java:699)
    at java.awt.EventQueue$3.run(EventQueue.java:697)
    at java.security.AccessController.doPrivileged(Native Method)
    at
java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:708)
    at
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
    at
java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
    at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
    at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
    at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
    at
org.txm.tbx.chartsengine.jfreechart.renderers.ItemSelector.popItemToDrawAsLast(ItemSelector.java:294)
    at
org.txm.tbx.chartsengine.jfreechart.themes.highcharts.defaulttheme.renderers.ItemSelectionXYLineAndShapeRenderer.drawItem(ItemSelectionXYLineAndShapeRenderer.java:309)
    at org.jfree.chart.plot.XYPlot.render(XYPlot.java:3782)
    at org.jfree.chart.plot.XYPlot.draw(XYPlot.java:3342)
    at org.jfree.chart.JFreeChart.draw(JFreeChart.java:1242)
    at org.jfree.chart.ChartPanel.paintComponent(ChartPanel.java:1629)
    at javax.swing.JComponent.paint(JComponent.java:1055)
    at javax.swing.JComponent.paintToOffscreen(JComponent.java:5232)
    at
javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1529)
    at
javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1452)
    at
javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:311)
    at javax.swing.RepaintManager.paint(RepaintManager.java:1249)
    at javax.swing.JComponent._paintImmediately(JComponent.java:5180)
    at javax.swing.JComponent.paintImmediately(JComponent.java:4991)
    at javax.swing.RepaintManager$3.run(RepaintManager.java:808)
    at javax.swing.RepaintManager$3.run(RepaintManager.java:796)
    at java.security.AccessController.doPrivileged(Native Method)
    at
java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
    at
javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:796)
    at
javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:769)
    at
javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:718)
    at javax.swing.RepaintManager.access$1100(RepaintManager.java:62)
    at
javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1677)
    at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
    at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:738)
    at java.awt.EventQueue.access$300(EventQueue.java:103)
    at java.awt.EventQueue$3.run(EventQueue.java:699)
    at java.awt.EventQueue$3.run(EventQueue.java:697)
    at java.security.AccessController.doPrivileged(Native Method)
    at
java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:708)
    at
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
    at
java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
    at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
    at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
    at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
    at
org.txm.tbx.chartsengine.jfreechart.renderers.ItemSelector.popItemToDrawAsLast(ItemSelector.java:294)
    at
org.txm.tbx.chartsengine.jfreechart.themes.highcharts.defaulttheme.renderers.ItemSelectionXYLineAndShapeRenderer.drawItem(ItemSelectionXYLineAndShapeRenderer.java:309)
    at org.jfree.chart.plot.XYPlot.render(XYPlot.java:3782)
    at org.jfree.chart.plot.XYPlot.draw(XYPlot.java:3342)
    at org.jfree.chart.JFreeChart.draw(JFreeChart.java:1242)
    at org.jfree.chart.ChartPanel.paintComponent(ChartPanel.java:1629)
    at javax.swing.JComponent.paint(JComponent.java:1055)
    at javax.swing.JComponent.paintToOffscreen(JComponent.java:5232)
    at
javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1529)
    at
javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1452)
    at
javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:311)
    at javax.swing.RepaintManager.paint(RepaintManager.java:1249)
    at javax.swing.JComponent._paintImmediately(JComponent.java:5180)
    at javax.swing.JComponent.paintImmediately(JComponent.java:4991)
    at javax.swing.RepaintManager$3.run(RepaintManager.java:808)
    at javax.swing.RepaintManager$3.run(RepaintManager.java:796)
    at java.security.AccessController.doPrivileged(Native Method)
    at
java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
    at
javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:796)
    at
javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:769)
    at
javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:718)
    at javax.swing.RepaintManager.access$1100(RepaintManager.java:62)
    at
javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1677)
    at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
    at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:738)
    at java.awt.EventQueue.access$300(EventQueue.java:103)
    at java.awt.EventQueue$3.run(EventQueue.java:699)
    at java.awt.EventQueue$3.run(EventQueue.java:697)
    at java.security.AccessController.doPrivileged(Native Method)
    at
java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:708)
    at
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
    at
java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
    at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
    at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
    at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:91) 

History

#1 Updated by Sebastien Jacquot over 4 years ago

I can't reproduce this bug but the code to pop the item was not accurate, a fix has just been committed.

#2 Updated by Sebastien Jacquot over 3 years ago

  • Target version changed from TXM 0.7.7 to TXM 0.8.0a (split/restructuration)

#3 Updated by Sebastien Jacquot over 2 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 80 to 100

#4 Updated by Sebastien Jacquot over 1 year ago

  • Target version changed from TXM 0.8.0a (split/restructuration) to TXM 0.8.0

Also available in: Atom PDF