Bug #1064

CA chart, JFC/Java2D, when reopening a CA editor after having changed the axis plan, the chart keeps the previous selected plan but the combo box is always reset to axis (1,2)

Added by Sebastien Jacquot almost 5 years ago. Updated over 2 years ago.

Status:Rejected Start date:10/17/2014
Priority:High Due date:
Assignee:- % Done:

100%

Category:Charts Spent time: -
Target version:TXM 0.7.8

Description

What is the expected behavior in this case ? At this moment, if I remember well, we have decided that the chart view should be reset when closing an editor.
This bug is linked to the general separation of code that we need to do, i.e. move all rendering related code from the TXM result objects (CA, CAH, Progression, etc.) to the Charts Engine layer. (e.g. the problem with the CA is that the axis plan is stored inside the CA object itself)
This bug is also linked to the general discussion of results and editors persistence and result tree nodes reopening management.

At this moment a simple and temporary workaround should be to update the combox from the CA axis value to keep a coherent state.

Validation tests

  • call CA
  • change axis plan combo to "(2,3)"
  • close the CA editor
  • re-open the CA from the corpus view node
  • the axis plan combo must be set to "(2,3)"
  • call CAH
  • compute rows from tool bar
  • change the number of clusters
  • close the CAH editor
  • re-open the CAH from the corpus view node
  • the CAH must be computed on rows and the number of clusters must be the same as modified before closing the editor

MD: OK Linux64
BP: OK, Ubuntu
SJ: OK, Win 7 x64

History

#1 Updated by Sebastien Jacquot almost 5 years ago

  • Description updated (diff)

#2 Updated by Sebastien Jacquot almost 5 years ago

  • Target version changed from TXM 0.7.6 to TXM 0.7.7

#3 Updated by Sebastien Jacquot almost 5 years ago

  • Status changed from New to Feedback

#4 Updated by Sebastien Jacquot almost 5 years ago

  • % Done changed from 0 to 80

The temporary workaround has been implemented and the combo box selected entry is now updated from the CA object when reopening an editor.

#5 Updated by Sebastien Jacquot almost 5 years ago

  • % Done changed from 80 to 50

TODO: the problem is the same with CA tool bar: show columns/show rows and CAH tool bar: clusters number, compute rows, compute columns (these values are also stored inside the TXM result objects but should be externalized to the rendering layer. Maybe not for the CAH compute rows/cols which seems more some computing functions than some rendering hints, e.g. exporting result functionality needs these data?).

#6 Updated by Sebastien Jacquot almost 5 years ago

  • % Done changed from 50 to 80

The temporary workaround has been implemented for CA and CAH tool bars and the combo boxes selected entries are now updated from the CA/CAH object data when reopening an editor.

#7 Updated by Matthieu Decorde almost 5 years ago

  • Description updated (diff)

#8 Updated by Sebastien Jacquot over 4 years ago

  • Description updated (diff)

#9 Updated by Matthieu Decorde over 4 years ago

  • Description updated (diff)
  • % Done changed from 80 to 90

#10 Updated by Sebastien Jacquot over 4 years ago

  • Target version changed from TXM 0.7.7 to TXM 0.7.8

Moved to 0.7.8 for the discussion about the expected behavior.

#11 Updated by Matthieu Decorde about 4 years ago

  • Target version changed from TXM 0.7.8 to TXM 0.8.0a (split/restructuration)

#12 Updated by Sebastien Jacquot over 3 years ago

  • Target version changed from TXM 0.8.0a (split/restructuration) to TXM 0.7.8

#13 Updated by Sebastien Jacquot over 3 years ago

  • Subject changed from RCP: 0.7.6, CA, JFC/Java2D, when reopening a CA editor after having changed the axis plan, the chart keeps the previous selected plan but the combo box is always reset to axis (1,2) to CA chart, JFC/Java2D, when reopening a CA editor after having changed the axis plan, the chart keeps the previous selected plan but the combo box is always reset to axis (1,2)
  • % Done changed from 90 to 80

#14 Updated by Sebastien Jacquot over 3 years ago

  • Description updated (diff)

#15 Updated by Sebastien Jacquot over 2 years ago

  • Status changed from Feedback to Rejected

This issue is obsolete with the new preferences management. See: org.txm.core.preferences.TXMPreferences and abstract initializers.

#16 Updated by Sebastien Jacquot over 2 years ago

  • % Done changed from 80 to 100

Also available in: Atom PDF