Bug #761

Updated by Serge Heiden about 6 years ago

Linux builds crash during start-up, during splash screen or start job

Error 1:
<pre>
[xcb] Unknown request in queue while dequeuing
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
java: ../../src/xcb_io.c :179 : dequeue_pending_request: l'assertion « !xcb_xlib_unknown_req_in_deq » a échoué.
</pre>

Error 2:
<pre>
[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
java: ../../src/xcb_io.c :274 : poll_for_event: l'assertion « !xcb_xlib_threads_sequence_lost » a échoué.
</pre>

Error 3:
<pre>
JVM terminated. Exit code=1
/usr/bin/java
-Xms512m
-Xmx1024m
-Dfile.encoding=UTF-8
-jar /usr/lib/TXM/TXM//plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib/TXM/TXM/TXM
-name TXM
--launcher.library /usr/lib/TXM/TXM//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20130521-0416/eclipse_1506.so
-startup /usr/lib/TXM/TXM//plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
--launcher.overrideVmargs
-exitdata 120007
- clearPersistedState
-run
-data /home/mdecorde/.txm
-user /home/mdecorde/.txm/user
-configuration /home/mdecorde/.txm/configuration
-vm /usr/bin/java
-vmargs
-Xms512m
-Xmx1024m
-Dfile.encoding=UTF-8
-jar /usr/lib/TXM/TXM//plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1440.jar
</pre>

Under Ubuntu 12.04 64-bit, a further error message dialog box indicates:
<pre>
The crashed program seems to use third-party or local libraries:

/home/sheiden/.txm/configuration/org.eclipse.osgi/bundles/119/1/.cp/libswt-gtk-4332.so
/home/sheiden/.txm/configuration/org.eclipse.osgi/bundles/119/1/.cp/libswt-cairo-gtk-4332.so
/home/sheiden/.txm/configuration/org.eclipse.osgi/bundles/119/1/.cp/libswt-pi-gtk-4332.so
/home/sheiden/.txm/configuration/org.eclipse.osgi/bundles/179/1/.cp/os/linux/x86_64/libunixfile_1_0_0.so
/home/sheiden/.txm/configuration/org.eclipse.osgi/bundles/119/1/.cp/libswt-atk-gtk-4332.so

It is highly recommended to check if the problem persists without those first.

Do you want to continue the report process anyway?
</pre>

Error 4:
<pre>
No message, but TXM is frozen
</pre>

Error 5:
<pre>
java: pthread_mutex_lock.c :113 : __pthread_mutex_lock: l'assertion « mutex->__data.__owner == 0 » a échoué.
</pre>

Back