Installation et configuration du projet java

Installation d'un IDE

Récupérer une version de eclipse, compatible avec votre système

Celle installée sur mon mac osx 10.8 est "Eclipse IDE for Java Developers, version: Juno Service Release 2, Build id: 20130225-0426"

Installation d'un client subversion

  1. Voir quelle version de subclipse est compatible avec la version d'eclipse installée sur votre poste
  2. Installer en allant dans le menu : Help > Install New Softwares
    • Ajouter l'url préconisé : http://subclipse.tigris.org/update_1.8.x et cocher à la fois les deux modules : Subclipse et SVNKit
    • Sous mac osx 10.8, il y a un problème d'indisponibilité sur la librairie JavaHL. Pour résoudre, aller dans Préférences d'eclipse, à Team > SVN > SVN Interface et choisir SVNKit.

Récupérer le projet

  1. Créer un projet java, File > New > Java Project, puis supprimer le sous dossier "src"
  2. Récupérer le projet svn : "File > Import > SVN > Checkout Projects from SVN
    • Choisir "Create a new repository location" et y inscrire cet url : https://forge.cbp.ens-lyon.fr/svn/hypermachiavel
    • Choisir le répertoire "SRC", puis Checkout as a project in the workspace, renommer "SRC" avec le même nom que le projet java crée précédemment.
Failed to load JavaHL Library.
These are the errors that were encountered:
no libsvnjavahl-1 in java.library.path
no svnjavahl-1 in java.library.path
no svnjavahl in java.library.path
java.library.path = .:/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java

Créer une nouvelle localisation du projet svn à importer

Choisir le répertoire distant "SRC"

Renommer répertoire à importer comme projet java.

Configurer le projet et lancer l'application

  1. Click droit sur le projet java pour choisir dans le menu contextuel : Properties
    • Aller dans l'onglet "Java Build Path"
    • Dans l'onglet "Source", ajouter les deux sous répertoires : src et res
    • Dans l'onglet "Libraries", ajouter toutes les librairies utiles au fonctionnement du programme Hypermachiavel, elles sont dans le répertoire lib
  2. Préparer une configuration de lancement de l'application
    • Aller dans le menu "Run > Run Configurations", et ajouter un nouvelle "Java application"
    • Dans l'onglet "Main", donner un nom à la configuration, choisir le projet java et la classe main, qui est le point d'entrée parmi les classes des différents packages, est : fr.triangle.hyperalign.gui/Hypermachiavel.java
    • Dans l'onglet "Arguments", ajouter des paramètres à la JVM suivants dans le champ "VM arguments" : -Xms250m -Xmx512m
      (même chose lorsque l'on devra lancer une version non binaire : java -jar -Xms250m -Xmx512m "Hypermachiavel.jar"). Voir ce billet à propos de la configuration jvm et des paramètres mémoires optimums.

Ajouter les répertoires "src" et "res" pour la compilation

Ajouter les librairies nécessaires à la compilation des classes

Dans une configuration de lancement de l'application, choisir la classe main

Et paramétrer des arguments pour la JVM

Eclipse_SVNProject1.png (62.1 kB) Severine Gedzelman, 03/13/2013 02:33 pm

Eclipse_SVNProject2.png (45.8 kB) Severine Gedzelman, 03/13/2013 02:33 pm

Eclipse_SVNProject3.png (61.1 kB) Severine Gedzelman, 03/13/2013 02:33 pm

Eclipse_ConfigJavaProject1.png (105.4 kB) Severine Gedzelman, 03/13/2013 02:58 pm

Eclipse_ConfigJavaProject2.png (133.9 kB) Severine Gedzelman, 03/13/2013 02:58 pm

Eclipse_ConfigJavaProject3.png (81.2 kB) Severine Gedzelman, 03/13/2013 03:10 pm

Eclipse_ConfigJavaProject4.png (84.2 kB) Severine Gedzelman, 03/13/2013 03:10 pm