Bug #2734

Corpora view is not well refreshed when deselecting the persistence "Keep" command on results that have hidden parent

Added by Sebastien Jacquot 12 months ago. Updated 12 months ago.

Status:Rejected Start date:01/22/2020
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:UI Spent time: -
Target version:TXM 0.8.1

Description

Corpora view is not well refreshed when deselecting the persistence "Keep" command on results that have hidden parent.

Steps to reproduce

  • create Specificities on a partition
  • => new "word" node appears, in "bold + italic"
  • select "Keep"
  • => node font changes to "bold"
  • unselect "Keep"
  • => node font stays to "bold" until the view is refreshed (with F5 or some other UI actions)

Notes

  • after some tests, org.txm.rcp.views.corpora.CorporaView.refreshObject(TXMResult), is not called so the problem is not is this method

History

#1 Updated by Sebastien Jacquot 12 months ago

  • Status changed from New to Rejected
  • % Done changed from 0 to 100

This issue is a side effect of a bug introduced to fix: #2686 that leads to infinite loop when setting persistable state to false.

Also available in: Atom PDF