Task #1212

RCP: 0.7.7, XML-TXM import module fails if some word has ana properties and not others

Added by Matthieu Decorde over 6 years ago. Updated 4 months ago.

Status:Closed Start date:12/18/2014
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:Import Spent time: -
Target version:TXM 0.7.7

Description

The problem is similar to the problem the XML/w had before the 0.7 version of TXM.

Solution

Do as in the XML/w :
1) discover all the ana properties type in all XML files before parsing texts
2) set to "" for the word which don't have a value for a ana properties discovered

History

#1 Updated by Serge Heiden over 6 years ago

This must be an optionnal behavior:
  • first because the XML-TXM format currently doesn't permit partial word encoding
  • second because the performance must seriously drop down

#2 Updated by Matthieu Decorde about 6 years ago

  • Description updated (diff)

#3 Updated by Matthieu Decorde 4 months ago

  • % Done changed from 80 to 100

#4 Updated by Matthieu Decorde 4 months ago

  • Status changed from New to Closed

In TXM 0.8.1, ana with same type are managed too

Also available in: Atom PDF