Bug #1648

Updated by Matthieu Decorde over 3 years ago

Text editors Some plugins are missing their contextual or menu and some keybindings ("Suppr" for instance)

trying to change key binding preferences raise an error :
<pre>
loader constraint violation: when resolving method "org.eclipse.e4.ui.bindings.internal.BindingTable.getPerfectMatch(Lorg/eclipse/jface/bindings/TriggerSequence;)Lorg/eclipse/jface/bindings/Binding;"
the class loader (instance of org/eclipse/osgi/internal/loader/EquinoxClassLoader) of the current class, org/eclipse/ui/internal/keys/BindingService,
and the class loader (instance of org/eclipse/osgi/internal/loader/EquinoxClassLoader) for resolved class, org/eclipse/e4/ui/bindings/internal/BindingTable,
have different Class objects for the type .getPerfectMatch(Lorg/eclipse/jface/bindings/TriggerSequence;)Lorg/eclipse/jface/bindings/Binding; used in the signature
</pre>
context is broken

Back