Task #1358

Updated by Sebastien Jacquot about 5 years ago

[WIP]

This issue is dedicated to validate the last changes made to manage the installation and the execution of TXM with our own embedded JRE rather than using the client JRE as before.
(You can see #989 for more information on what has been developed and researches done about this question.)

[NOTE: this text should be moved/copied to the dev Wiki, it is for summary purpose of the current state, not really dedicated to this issue validation tests]

The current JRE versions embedded in TXM setups according to the OS are :
* Windows 32bit: 1.7.0_75-b13 (Oracle)
* Windows 64bit: 1.7.0_75-b13 (Oracle)
* Linux 32bit: 1.7.0_75-b13 (Oracle)
* Linux 64bit: 1.7.0_75-b13 (Oracle)
* Mac OS X 64bit > 10.6: 1.6.0_65-b14-466.1-11M4609 (Apple)
* Mac OS X 64bit <= 10.6: 1.6 XXXXXXXX (Apple)

They can be found on the SMB at:
* SMB/

[/NOTE]

h3. Validation test

* optional: uninstall all Java JRE/JDK from your system
=> to check there is no installed Java, open a command line "cmd" console (Windows system) or a terminal (Linux and Mac system) and type "java". The console must say something like "unknown command"

* install the last TXM 0.7.7beta2 setup for your system from here: xxxxx
=> installer must not complain about Java installation
* run TXM
* go to "Help\About TXM\Installation Details\Configuration" and check that you have the 3 following lines:
** "java.home=..." line that must be as following according to your OS:
*** For Windows: java.home=[TXM Install Directory]\jre\jre
where "[TXM Install Directory]" must be your TXM installation path.
*** For Mac OS X: java.home=/Applications/TXM/TXM/jre/Contents/Home
*** For Linux: java.home=/usr/lib/TXM/TXM/jre/Contents/Home
** java.runtime.version=1.7.0_75-b13
*** except for Mac OS X where the entry must be java.runtime.version=1.6.0_65-b14-466.1-11M4609
** java.vm.name=Java HotSpot(TM) 64-Bit Server VM

* please provide your exact OS version and architecture (32bit or 64bit)
* please precise if you have uninstalled all Java JRE/JDK from your system before doing the validation test

Back