Task #1007

Updated by Sebastien Jacquot almost 5 years ago

NOTE: we may need to simplify the management of all the projects of TXM by using a Team Projet Set (TPS) or using Maven, Buckminster, etc. See: http://www.eclipseonetips.com/2010/01/25/checkout-multiple-projects-automatically-into-your-eclipse-workspace/
This will be especially useful/needed when we'll split the layers and commands to separated plug-in projects.

When the TXM dev Wiki user accounts will be reestablished, edit http://txm.sourceforge.net/wiki/index.php?title=Special:UserLogin&returnto=Build+the+toolbox+and+the+application:

in the "install" subsection:
- links to Eclipse 4.3 and deltapack are dead or wrong
- Babel plug-in note missing ? and/or make a note for full "installation" will all the projects from SVN ?

To redact, note on the real Eclipse version compatible with Delta pack may be needed:

<pre>
Babel : BabelLanguagePack-eclipse-fr_4.4.0.v20140623020002.zip
Eclipse for RCP and RAP Developers : Build id: 20140612-0600 http://eclipse.org/downloads/packages/eclipse-rcp-and-rap-developers/lunar
Delta pack 4.4-201406061215 : http://download.eclipse.org/eclipse/downloads/drops4/R-4.4-201406061215
</pre>

in the "plugins" subsection:
- NOTE: SVN 1.7.xx connector version needed (not the latest which seems to use another protocol)
- NOTE: some anti-viruses may block the access to dist.springsource.com which is the server of the Groovy plug-in (at least Avast and Kaspersky) therefore disabling the anti-virus may help if the Eclipse updating hangs up on this site
- NOTE: the Groovy compiler of TXM projects is level 2.3 (it's normally the default compiler when installing the plug-in)
- anyway to get the usage of the e4 tools plug-in ? seems to be used for Eclipse RCP 3.7 => RCP 4.3 compatibility ?
- NOTE: put Babel in Delta pack and provides this global pack to avoid getting wrong versions
- NOTE: Delta pack purpose is the build for multiple platforms

Back