Bug #635

Updated by Matthieu Decorde about 6 years ago

see: LINK

The R package installation validation test is too strict and can cause TXM installation to stop even if package _can_ work correctly

First solution was to call "library("...")" for each package during TXM start-up job.


-
But the "library("FactoMineR")" test does not works (it does work when called from a R script).
The tests has been moved to a new command in the Help menu: "Check R packages" packages"-
This problem seems to be caused by the #761 bug


h3. Validation test

* Run R
* exec *remove.packages("FactoMineR")* (don't work on my computer, but this is the official command to remove a package.)
* Run TXM
* A message should alert that FactoMineR is not present and show the Commands that won't work

To restore FactoMineR :

* Run R
* exec *install.packages("FactoMineR")*

Back