résultat campagne de test no1 TXM 0.7.6.txt

Matthieu Decorde, 11/12/2014 11:37 am

Download (4.1 kB)

 
1
*TEST SETUPS 0.7.6 :*
2

    
3
Ubuntu 13.04 64bits VM avec proxy
4
- setup : TXM_0.7.6_Linux64.deb lance l'Ubuntu Software Center qui bloque sur les petits points en cercle (icône de chargement), on ne voit même pas le message d'accueil. (L'Ubuntu Software Center se lance bien par ailleurs si je le lance directement)
5
(lié au bug https://forge.cbp.ens-lyon.fr/redmine/issues/1025 ?)
6
Je viens de tenter l'install en passant par dpkg, ça bloque aussi sur l'install des packages de R ce qui semble normale car R est lancé sans les paramètres de proxy.
7

    
8
Ubuntu 13.04 64bits VM sans proxy
9
- setup : idem pour le bug du blocage de l'Ubuntu Center
10
(lié au bug https://forge.cbp.ens-lyon.fr/redmine/issues/1025 ?)
11
L'install fonctionne bien en passant par "dpkg"
12
- TXM : l'UI bloque au premier lancement après "Reloading subcorpora and partitions....Done.", le browser affiche bien la page html de bienvenue
13
Après un kill et un relancement, l'UI ne s'ouvre plus, il ne se passe rien après le splash screen
14

    
15
Mac OS X 10.9.6 VM avec proxy
16
- setup : l'install bloque sur "Running package scripts" lors de l'install des packages R, la configuration du proxy n'est pas passé à R avant l'install des packages (plusieurs solutions pour un install online : voir "http_proxy" ou "wget" puis installation locale du package)
17
- TXM : il manque le plugin natif de gestion de proxy "org.eclipse.core.net.xxxxxx"
18

    
19
Win XP 32bits sous proxy
20
- TXM : en lançant TXM on l'entend ramer mais y a pas de splashscreen puis au bout d'un moment ça semble ne faire plus rien. Au bout de 15min j'ai désactivé la connexion réseau et la l'UI s'ouvre direct.
21
Une fois que TXM est lancée, dans les connexions réseaux le proxy system est bien configuré et l'active provider est en "Native". Mais il doit y avoir un truc qui essaie de se connecter avant le lancement ?
22
J'ai tracé les connexions et TXM tente effectivement de se connecter avant le splashscreen (qui n'apparaît d'ailleurs pas) et avant l'UI donc. 
23
TODO : revérifer que la config "Native" n'est pas un résidu d'un ancien fichier "org.txm.rcpapplication.prefs" dans un emplacement temporaire mais en tout cas le plugin natif org.eclipse.core.net.
24
- Au démarrage RServe ne se lance pas, log : 
25
<pre>
26
Starting Statistics Engine
27
Démarrage du moteur de statistiques par l'utilisateur :  distant: false port: 6311 debug: false
28
Démarrage de R avec le chemin d'accès C:\Program Files\TXM\R\bin\R.exe
29
Démarrage de R avec la ligne de commande: [C:\Program Files\TXM\R\bin\R.exe, -e, library(Rserve);Rserve(FALSE,port=6311,args='--RS-encoding utf8 --no-save --slave --encoding utf8  --internet2')" --no-save --slave --encoding utf8  --internet2]
30
Moteur statistique lancé 
31
Rserve>Starting Rserve...
32
Rserve> "C:\PROGRA~1\TXM\R\library\Rserve\libs\i386\Rserve.exe" --RS-encoding utf8 --no-save --slave --encoding utf8  --internet2
33
...................
34
Impossible de démarrer RServe : org.txm.stat.engine.r.RWorkspaceException: ** Le chemin du programme du serveur statistique a été renseigné mais sa recherche a échoué C:\Program Files\TXM\R\bin\R.exe
35
org.txm.stat.engine.r.RWorkspaceException: ** Le chemin du programme du serveur statistique a été renseigné mais sa rechercheéchoué C:\Program Files\TXM\R\bin\R.exe
36
    at org.txm.stat.engine.r.RWorkspace.initRserve(RWorkspace.java:308)
37
    at org.txm.stat.engine.r.RWorkspace.startExec(RWorkspace.java:494)
38
    at org.txm.Toolbox.startStatEngine(Toolbox.java:688)
39
    at org.txm.Toolbox.initialize(Toolbox.java:555)
40
    at org.txm.rcpapplication.ApplicationWorkbenchAdvisor.initializeUI(ApplicationWorkbenchAdvisor.java:1066)
41
    at org.txm.rcpapplication.ApplicationWorkbenchAdvisor.access$2(ApplicationWorkbenchAdvisor.java:1060)
42
    at org.txm.rcpapplication.ApplicationWorkbenchAdvisor$2.run(ApplicationWorkbenchAdvisor.java:470)
43
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
44
Chargement des sous-corpus et des partitions...
45
Chargement de l'espace de travail ࡰartir du fichier C:\Documents and Settings\s\TXM\workspaces\default.xml
46
Terminé
47
Starting Charts Engine
48
Toolbox states: cqp:true R :false Espace de travail : true
49
Initializing the charts SWT component provider
50
Loading views
51
Pret
52
Effectué en 51 sec. (51078 msec) 
53
</pre>
54